Hi All - as the title states.
In the middle of a Sunday afternoon in UWA car park during Open Day my battery died.
I attempted to jump it with a borrowed jump pack using the front connections under the bonnet - no luck. Used 3 separate packs & then tried from a huge diesel Ford Ranger - no luck.
Then I stupidly tried directly onto the battery in the boot with the Ranger again and still no luck.
I got a brand new battery and fitted it - YAY - it started and drove BUT my idrive, radio & bluetooth (phone) don't work. Everything else seems to work ok.
I have checked every glove box and boot fuse and they all check out ok. Anybody got any ideas as to what needs removing to be checked etc?
I normally do everything myself and this has completely thrown me as I'm not having much success downloading INPA NCS onto a laptop either. My ELM USB/ TORQUE App is useless with this car.
The local specialist wants $90 per hour to look at it which I find extortionate for an old car ('06).
Any ideas please anyone before I get the credit card out?