Results 1 to 4 of 4

Thread: Service message showing

  1. #1
    Join Date
    Mar 2019
    Location
    Lake Macquarie NSW
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default Service message showing

    Have a service message coming up on my dash upon turning on the ignition. I had the service done elsewhere (not at BMW). Can anyone tell me how to get rid of this message please. Thanks.

  2. #2
    Join Date
    Aug 2009
    Posts
    2,287
    Thanks
    11
    Thanked 47 Times in 42 Posts

    Default

    What's the car mate?

  3. #3
    Join Date
    Mar 2019
    Location
    Lake Macquarie NSW
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default

    Sorry, the car is a 2011 X3 F25 20D.

  4. #4
    Join Date
    Aug 2009
    Posts
    2,287
    Thanks
    11
    Thanked 47 Times in 42 Posts

    Default

    Try this..

    All doors closed. Turn ignition on and do not start the engine.
    Hold the ODO button for 10 seconds
    The menu will show up with the current warning ready to be reset, if not, push the ODO button to cycle thru the options. Once you get the option you want like oil service push on the ODO again and hold and you will get the Reset? with a question mark. Push and HOLD the ODO button once more until you get the Resetting indicator showing progress and then completion. Release the ODO button and you are done.

    Or maybe:

    Turn on ignition.
    Push odo button for 10 seconds.
    Enter the sum of the last five numbers of your vin in the code by pressing the odo button.
    You'll enter into the menu, by pressing the odo button you can make your changes.

    OR this..


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •